App and ShopPulse Response Times Slow

Incident Report for MachineMetrics

Resolved

Application performance has improved to acceptable levels. While we are closing this incident, we will continue to make improvements to application performance and stability.
Posted May 20, 2026 - 14:16 EDT

Update

Response times have come down considerably but we are still working to make additional improvements.
Posted May 20, 2026 - 13:05 EDT

Investigating

Response times for all endpoints are slow. We have been investigating the issue. We will post updates as more information is available.
Posted May 20, 2026 - 10:29 EDT
This incident affected: Web Application.