Some Web Pages Failing

Incident Report for MachineMetrics

Resolved

The fix has been deployed to all production environments and pages should be loading normally now. A page reload may be required for the fix to apply in some cases.
Posted Jun 18, 2026 - 14:27 EDT

Update

The fixes impacting page loads are deploying at this time
Posted Jun 18, 2026 - 14:07 EDT

Identified

We are currently implementing fixes for an issue which is impacting some pages of the application. ShopPulse is unaffected, API endpoints and data ingestion are not impacted. There are a small number of pages that are failing to load.
Posted Jun 18, 2026 - 13:29 EDT
This incident affected: Web Application.