Some System Emails are Bouncing
Incident Report for MachineMetrics
Resolved
After further investigation, we've confirmed that this only affected a single account.
Posted 6 months ago. Dec 21, 2018 - 10:02 EST
Investigating
We are investigating an issue which is causing some emails sent from our system to not reach users' inboxes. This is at least known to affect inviting new users to a company.
Posted 6 months ago. Dec 21, 2018 - 09:38 EST
This incident affected: Web Application.