AWS Outage

Incident Report for MachineMetrics

Resolved

Our services were affected earlier today by a widespread AWS outage that caused disruptions across multiple providers. We implemented a the necessary workarounds based on updated guidance, and this restored all systems to normal operation.

Everything is now fully operational. We’ll continue to monitor the situation.
Posted Oct 20, 2025 - 21:19 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 15:58 EDT

Monitoring

All systems are operational at this moment; however, due to instability reported by our cloud services provider throughout the day, we will leave this incident open and will post updates as more information is available.
Posted Oct 20, 2025 - 15:45 EDT

Identified

Outage with AWS
Posted Oct 20, 2025 - 15:40 EDT
This incident affected: Web Application, Data Processing Services, and Operator Dashboard.